1993 Cobra Registry

http://www.1993cobra.com
It is currently Tue Jul 25, 2017 10:34 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Vacuum Lines
PostPosted: Fri Jul 07, 2017 10:29 pm 
Offline

Joined: Tue Jul 15, 2014 3:09 pm
Posts: 253
Location: Los Angeles, CA
Hey guys, can anyone give me some advice on vacuum lines?

One of my lines has broken on both sides and I'm not sure how to reconnect it. Do they make connectors that fit the specific lines? Or is it better to just replace the line? And if so, how do I know the length and where to get it?

Any advice would be helpful. Sorry for the amateur questions...


Top
 Profile  
 
 Post subject: Re: Vacuum Lines
PostPosted: Sat Jul 08, 2017 11:44 am 
Offline
User avatar

Joined: Sun May 04, 2014 6:22 pm
Posts: 477
Location: DFW
If it's broken on both sides, take it to your favorite auto parts store and slap it on the counter. Don't say a word. Just stare them down. :shock:

_________________
'11 GT500 FR750 2.9 Whipple, '04 Mystichrome Terminator vert, '02 Mustang GT, 00R, '93 Cobra #1447, '89 Mustang GT vert.

Image


Top
 Profile  
 
 Post subject: Re: Vacuum Lines
PostPosted: Sat Jul 08, 2017 2:03 pm 
Offline

Joined: Tue Jul 15, 2014 3:09 pm
Posts: 253
Location: Los Angeles, CA
Goose17 wrote:
If it's broken on both sides, take it to your favorite auto parts store and slap it on the counter. Don't say a word. Just stare them down. :shock:


:lol:

On my way...


Top
 Profile  
 
 Post subject: Re: Vacuum Lines
PostPosted: Wed Jul 12, 2017 10:36 pm 
Offline

Joined: Tue Jul 15, 2014 3:09 pm
Posts: 253
Location: Los Angeles, CA
Slapped it on the counter and low and behold they helped me out!












No they didn't but I fixed it. Thanks guys


Top
 Profile  
 
 Post subject: Re: Vacuum Lines
PostPosted: Wed Jul 12, 2017 10:38 pm 
Offline
User avatar

Joined: Sun May 04, 2014 6:22 pm
Posts: 477
Location: DFW
lukewood2 wrote:
Slapped it on the counter and low and behold they helped me out!


No they didn't but I fixed it. Thanks guys


Funny! :lol:

Glad you got it fixed.

_________________
'11 GT500 FR750 2.9 Whipple, '04 Mystichrome Terminator vert, '02 Mustang GT, 00R, '93 Cobra #1447, '89 Mustang GT vert.

Image


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group